Temporary Outage Resolved
Incident Report for drchrono
Resolved
drchrono is pleased to report that our engineering team has implemented a resolution to address the recent service outage. We want to thank our users for their patience and support as we worked to address this matter as quickly as possible.
Posted 10 months ago. Jan 17, 2018 - 13:05 PST
Update
Earlier, we experienced the temporary inability to load certain pages on our desktop version. Our engineering team enacted a fix.
To push the fix, please clear the browser cache or hit "Cmd+Shift+R" and that'd be "Ctrl+Shift+R" for Windows users.
Posted 10 months ago. Jan 17, 2018 - 12:53 PST
Monitoring
Earlier, we experienced the temporary inability to load certain pages on our desktop version. Our engineering team enacted a fix. To push the fix, please clear the browser cache or hit Cmd+Shift+R to see the updated version. We appreciate your patience and understanding.
Posted 10 months ago. Jan 17, 2018 - 12:48 PST