Check In Application Issue
Incident Report for drchrono
Resolved
The Check In Application issue has been resolved. Thank you for your patience and understanding.
Posted 10 months ago. Dec 05, 2017 - 10:18 PST
Identified
We are currently experiencing an issue with our Check-In application. Our engineering team is aware, and working to enact a fix. We will update you as soon as we have more information or reach a resolution.
Posted 10 months ago. Dec 05, 2017 - 09:01 PST