Site Slowness
Incident Report for drchrono
Resolved
drchrono is pleased to report that our engineering team has implemented a resolution to address the recent site slowness. We want to thank our users for their patience and support as we worked to address this matter as quickly as possible.
Posted 10 months ago. Jan 22, 2018 - 06:03 PST
Identified
drchrono is currently experiencing site slowness. Please be aware that we take this very seriously and our engineering team is actively investigating and working to resolve this situation as quickly as possible. We will provide another update via this status page as soon as possible.
Posted 10 months ago. Jan 22, 2018 - 05:54 PST