Billing Screens
Incident Report for drchrono
Resolved
drchrono is pleased to report that our engineering team has implemented a resolution to address the billing screen service outage. We want to thank our users for their patience and support as we worked to address this matter as quickly as possible.
Posted 4 months ago. Jan 26, 2018 - 10:46 PST
Identified
drchrono is currently experiencing a significant billing screen outage. Please be aware that our engineering team is prioritizing this issue and working to resolve this situation as quickly as possible. We will provide another update via this status page as soon as possible.
Posted 4 months ago. Jan 26, 2018 - 08:51 PST