Real Time Eligibility remains offline.
Incident Report for drchrono
Resolved
The issues with Real Time Eligibility has been resolved. We apologize for any inconvenience that this may have caused.
Posted 7 months ago. Mar 18, 2019 - 12:06 PDT
Identified
We are working with Trizetto to establish connectivity to Real Time Eligibility services that remain offline after maintenance performed this weekend. We do not yet have an estimated time to a resolution but will update this status page as a fix is implemented or more information becomes available.
Posted 7 months ago. Mar 18, 2019 - 10:31 PDT
This incident affected: drchrono.com.