Quest Connectivity Issue
Incident Report for drchrono
Resolved
Quest Diagnostics has resolved the site slowness and connectivity issues that were affecting all incoming and outgoing Quest lab orders. Please resubmit any lab orders that may have been affected.
Posted 4 months ago. Jul 11, 2018 - 11:37 PDT
Identified
Quest Diagnostics is currently experiencing site slowness and connectivity issues with all Quanum e-lab applications which are affecting all incoming and outgoing Quest lab orders within the drchrono EHR. Quest's engineers are in the process of working to resolve this issue. We will keep you apprised of any updates as we are made aware.
Posted 4 months ago. Jul 09, 2018 - 12:35 PDT
This incident affected: drchrono.com.