LabCorp Connectivity Issues
Incident Report for drchrono
Resolved
The issues that we were experiencing sending lab orders have been resolved. Labs are properly flowing through the system at this time. Please resend any outstanding lab orders and let us know if you have any problems.
We apologize for the inconvenience that this may have caused you.
Posted 8 months ago. Mar 26, 2018 - 12:53 PDT
Identified
drchrono is currently experiencing issues processing LabCorp orders. Please be aware that our engineering team is prioritizing the investigation of this issue and working to resolve this situation as quickly as possible. We will provide another update via this status page as soon as possible.
Posted 8 months ago. Mar 26, 2018 - 07:19 PDT