Quest & LabCorp Outage
Incident Report for drchrono
Resolved
drchrono is pleased to report that our engineering team has enacted a fix to address the previously reported issues with labs. We want to thank our users for their patience and support as we worked to address this matter as quickly as possible.
Posted 6 months ago. Mar 21, 2018 - 11:10 PDT
Identified
drchrono is currently experiencing a service outage related to sending labs through Quest and LabCorp. Please be aware that our engineering team is prioritizing the investigation of this issue and working to resolve this situation as quickly as possible. We will provide another update via this status page as soon as possible.
Posted 6 months ago. Mar 21, 2018 - 06:32 PDT