Site Wide Failure
Incident Report for drchrono
Resolved
The incident was resolved by our Engineering team at approximately 5:45pm PDT. We apologize for any delays or interruption of service this may have caused you.
Posted 25 days ago. May 31, 2019 - 08:39 PDT
Investigating
DrChrono experienced a major service outage last night during our weekly maintenance period. It lasted a period of 15 minutes from 5:25pm PDT through 5:40pm PDT where some of our users experienced degraded performance.
Posted 25 days ago. May 31, 2019 - 08:38 PDT
This incident affected: drchrono.com.