Unable to order labs
Incident Report for DrChrono
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 06:37 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 15, 2020 - 14:53 PDT
Investigating
We are currently investigating an issue that is preventing users from submitting both Quest and LabCorp orders. The error message displayed states "Unknown error creating your orders. Try again?". We will post an update as soon as we have more information.
Posted Sep 15, 2020 - 12:36 PDT
This incident affected: drchrono.com and drchrono iPad EHR.