Resending Controlled Substances via The Medication List
Incident Report for drchrono
Resolved
This incident has been resolved. Thank you for your patience.
Posted 22 days ago. Jun 28, 2019 - 11:37 PDT
Investigating
We are currently investigating an issue whereby users are experiencing trouble attempting to prescribe controlled substance via the Medication List electronically. In the meantime, please prescribe controlled substances via the send eRx screen until a fix is put in place for this issue. Thank you for your patience.
Posted 22 days ago. Jun 28, 2019 - 07:57 PDT
This incident affected: eRx service.