Site Slowness
Incident Report for drchrono
Resolved
A fix has been enacted to remedy our degraded performance. We apologize for the inconvenience, and appreciate your patience.
Posted about 1 year ago. Nov 06, 2017 - 12:54 PST
Monitoring
We are currently experiencing issues with our hosting partner and internet service providers. This is unfortunately out of our control at this time.

Our engineers are in contact with our hosting partner and working diligently toward a resolution.
At this time we do not have an estimated time for repair.
As more information becomes available or a a solution is in place we'll let you know immediately.
Posted about 1 year ago. Nov 06, 2017 - 11:34 PST