Updox Faxing Issue
Incident Report for drchrono
Resolved
The issue with inbound/outbound faxing is now resolved. Thank you for your patience while we worked to get to the root cause and enact a fix.
Posted 8 months ago. Dec 04, 2017 - 13:05 PST
Identified
A telecom issue has been identified across the country. This is the cause of our inbound / outbound faxing issues. Our Team is monitoring the situation and keep you apprised of any updates.
Posted 8 months ago. Dec 04, 2017 - 10:06 PST