Clinical Notes
Incident Report for drchrono
Resolved
drchrono is pleased to report that our engineering team has implemented a resolution to address the issues previously reported with signing and locking clinical notes. Everything is functioning as it should.

For the time being, please wait a moment before clicking "Sign & Lock" to allow the note to fully render. Thank you for your patience and support as we worked to address this matter as quickly as possible.
Posted 13 days ago. May 07, 2018 - 17:23 PDT
Identified
drchrono is currently experiencing issues with clinical notes. Our engineering team is prioritizing the investigation and working to resolve this situation as quickly as possible. We will provide another update via this status page as soon as possible.
Posted 13 days ago. May 07, 2018 - 13:46 PDT