DrChrono.com site issues
Incident Report for drchrono
Resolved
Our engineers have identified and fixed the issue. DrChrono.com is back up and running. Please clear your browser history cache and login back to your account to access all functionalities.
Posted 3 months ago. Oct 25, 2018 - 21:43 PDT
Identified
Our engineers are actively working on site issues on drchrono.com. We apologize for the inconvenience.
Posted 3 months ago. Oct 25, 2018 - 20:35 PDT
This incident affected: drchrono.com.