Website outage
Incident Report for drchrono
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 08, 2018 - 20:34 PST
Monitoring
The site is going back to normal. If the pages look broken to you please clear the browser cache or use Ctrl+Shift+R (Cmd+Shift+R on Mac) to bypass the cache.
Posted 2 months ago. Mar 08, 2018 - 19:22 PST
Identified
We're aware of the problems accessing drchrono.com internal website and using iPad EHR app and working on fixing it ASAP.
Posted 2 months ago. Mar 08, 2018 - 18:58 PST