Intermittent Performance Issues
Incident Report for drchrono
Resolved
A fix has been enacted to remedy our degraded performance. We apologize for the inconvenience and appreciate your patience.
Posted about 1 year ago. Nov 21, 2017 - 11:15 PST
Investigating
We want to let you know that we are aware of, and investigating, reports of intermittent performance issues. We will work to get to the bottom of the situation and aim to resolve as soon as possible.
Posted about 1 year ago. Nov 21, 2017 - 10:53 PST