Slowness and data not saving
Incident Report for DrChrono
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 14:14 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2019 - 12:46 PST
Identified
The issue has been identified and we are actively working on a resolution.
Posted Nov 14, 2019 - 12:16 PST
Investigating
We are currently investigating this issue.
Posted Nov 14, 2019 - 12:03 PST
This incident affected: drchrono.com and drchrono iPad EHR.