System slowness
Incident Report for drchrono
Resolved
This incident has been resolved.
Posted Aug 19, 2019 - 13:57 PDT
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Aug 19, 2019 - 11:07 PDT
Identified
Our Engineering team has identified the issue area and are working to resolve ASAP.
Posted Aug 19, 2019 - 10:04 PDT
Investigating
We are currently investigating the issue and will post updates ASAP.
Posted Aug 19, 2019 - 09:07 PDT
This incident affected: drchrono.com and drchrono iPad EHR.