DrChrono Web System Issues

Incident Report for DrChrono

Resolved

We have resolved the intermittent system issues experienced over the past three days. The root cause was related to brief scenarios where one of the supporting databases was unable to accept new connections, resulting in a small percentage of requests (approximately 3%) returning errors.

Overnight, we implemented performance improvements to reduce system strain and help isolate the issue. Today, we made additional infrastructure adjustments to address the connection limitations and monitored system performance throughout peak usage hours. The system is now operating normally.

We will publish a detailed root cause analysis (RCA) on our status page in the coming days.
Posted Mar 25, 2026 - 14:36 PDT

Update

We are continuing to investigate the issue causing intermittent symptoms across multiple areas of the system, and you may encounter the following error messages:

“Bad Gateway”
“Server is Busy”
“Failed to Load Footer”

Our engineering team remains actively engaged and is working to resolve the issue as quickly as possible.

As a temporary solution, refreshing the page may clear the error.

We appreciate your continued patience and will provide further updates as more information becomes available.
Posted Mar 25, 2026 - 10:41 PDT

Investigating

We have identified an issue causing intermittent symptoms across multiple areas of the system, and you may encounter the following error messages:

“Bad Gateway”
“Server is Busy”
“Failed to Load Footer”

Our engineering team is all-hands-on-deck and investigating the root cause to restore full functionality as quickly as possible.

We understand the impact this may have and appreciate your patience while we resolve the issue.

We are working on this as quickly as we can and will provide updates as they become available.
Posted Mar 25, 2026 - 09:59 PDT
This incident affected: drchrono.com.