Vendor-Quest Labs
Incident Report for DrChrono
Resolved
Quest has resolved their outage. We are sorry for any issues this may have caused.
Posted Apr 17, 2024 - 13:32 PDT
Update
We are continuing to investigate this issue.
Posted Apr 17, 2024 - 13:32 PDT
Investigating
Quest, our lab vendor, is currently experiencing an outage that may affect lab results and lab orders. We will continue to use this page to monitor as we learn more from Quest. We apologize for any issues this may cause.
Posted Apr 17, 2024 - 10:17 PDT
This incident affected: drchrono.com.