Appointments not Saving on the Calendar
Incident Report for DrChrono
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 07:33 PDT
Investigating
We are currently investigating this issue.
Posted Mar 16, 2020 - 06:29 PDT
This incident affected: drchrono.com.