New Task Center Issue
Incident Report for drchrono
Resolved
drchrono is pleased to report that our engineering team has implemented a fix to address the previously reported issues with the new task center. We want to thank our customers for their patience and support as we worked to address this matter as quickly as possible.
Posted 8 months ago. Mar 19, 2018 - 10:51 PDT
Identified
drchrono is currently experiencing temporary issues with the new task center. Please be aware that our engineering team is prioritizing the investigation of this issue and working to resolve this situation as quickly as possible. We will provide another update via this status page as soon as possible.
Posted 8 months ago. Mar 19, 2018 - 09:45 PDT