System Slowness

Incident Report for DrChrono

Resolved

Our engineering team has resolved the issue, and system performance has returned to normal. We appreciate your patience.
Posted Mar 30, 2026 - 15:05 PDT

Investigating

We are aware of an issue causing system slowness for some users. Our engineering team is actively investigating and working toward a resolution. We will share additional updates as more information becomes available.
Posted Mar 30, 2026 - 13:48 PDT
This incident affected: drchrono.com.