DrChrono Slowness

Incident Report for DrChrono

Resolved

DrChrono has resolved the issue that was causing slowness for a limited set of users. System performance has returned to normal, and we will continue to monitor to ensure ongoing stability.
Posted Apr 07, 2026 - 10:34 PDT

Monitoring

DrChrono has implemented mitigation steps to address the earlier reported slowness affecting a limited set of users while we continue to isolate the root cause. We are currently monitoring system performance to ensure stability.
Posted Apr 06, 2026 - 13:41 PDT

Investigating

DrChrono has identified that a limited set of users may be experiencing slowness within the application. We are investigating the issue and will post updates every 60 minutes or as soon as they become available.
Posted Apr 06, 2026 - 12:37 PDT
This incident affected: drchrono.com.