Third Party Vendor: ID.me
Incident Report for DrChrono
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 04:25 PST
Update
ID.me, our third-party vendor, has resolved their incident. Thank you for your patience and understanding.
Posted Nov 19, 2024 - 04:25 PST
Monitoring
ID.me, our third-party vendor, has implemented a fix and is continuing to monitor their system. We will continue to provide updates as new information becomes available. Thank you for your patience and understanding.

Please follow their status page for more information: https://status.id.me/
Posted Nov 18, 2024 - 11:10 PST
Update
ID.me, our third-party vendor, is continuing to work on a fix to address their ongoing platform degradation. We will continue to provide updates as new information becomes available. Thank you for your patience and understanding.

Please follow their status page for more information: https://status.id.me/
Posted Nov 18, 2024 - 09:53 PST
Update
ID.me, our third-party vendor, has identified an issue within their system and is actively working on deploying a fix. We will continue to provide updates as new information becomes available. Thank you for your patience and understanding.

Please follow their status page for more information: https://status.id.me/
Posted Nov 18, 2024 - 08:48 PST
Identified
ID.me, our third-party vendor, has identified an issue within their system and is actively working on deploying a fix. We will continue to provide updates as new information becomes available. Thank you for your patience and understanding.


Please follow their status page for more information: https://status.id.me/
Posted Nov 18, 2024 - 07:29 PST
This incident affected: drchrono.com and drchrono iPad EHR.