Site slowness
Incident Report for DrChrono
Resolved
We've resolved the issue that was causing slowness issues earlier this today and we're continuing to optimize our servers and databases to improve overall performance.
Posted Sep 08, 2020 - 14:01 PDT
Monitoring
Thank you for your patience. We've implemented a fix and we're monitoring the results.
Posted Sep 08, 2020 - 13:30 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 08, 2020 - 13:03 PDT
Investigating
We are currently investigating an issue that is causing general slowness and data not to save. We will provide an update as soon as possible regarding this issue.
Posted Sep 08, 2020 - 12:19 PDT
This incident affected: drchrono.com.