Quest Lab Results

Incident Report for DrChrono

Resolved

The DrChrono team has resolved issues with Quest Labs. We are sorry for any inconveniences this caused. If you have any further questions please reach out to support.
Posted May 23, 2024 - 06:59 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 22, 2024 - 09:19 PDT

Investigating

We are currently experiencing an issue importing lab results from Quest Labs. Our engineering team is aware of the issue and is actively working towards a resolution in partnership with Quest Labs. Lab result delivery may be delayed until the issue is resolved.
Posted May 22, 2024 - 08:28 PDT
This incident affected: 3rd party services (Quest Diagnostics).