Site slowness
Incident Report for drchrono
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 16, 2019 - 10:22 PDT
Monitoring
Our team has identified the issue and implemented a fix. We are monitoring results.
Posted about 1 month ago. Sep 16, 2019 - 09:37 PDT
Investigating
We have received reports of site slowness and some of our users unable to save information. Our Engineering team is working on a fix.
Posted about 1 month ago. Sep 16, 2019 - 09:33 PDT
This incident affected: drchrono.com and drchrono iPad EHR.