Quest Diagnostics Ordering Disruption
Incident Report for drchrono
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 19, 2019 - 09:08 PDT
Investigating
We are currently investigating an issue whereby Quest orders are not able to be placed within the DrChrono system. This issue impacts the ability to search for a test code or use a preset favorite code. We will share updates as we receive them.
Posted 7 months ago. Mar 19, 2019 - 08:21 PDT
This incident affected: drchrono.com and drchrono iPad EHR.