Vendor Outage Quest Diagnostics

Incident Report for DrChrono

Resolved

Quest has resolved their issues. We are sorry for any issues this may have caused.
Posted Jul 25, 2024 - 11:29 PDT

Investigating

Quest Diagnostics has confirmed they are experiencing issues on their end. Our team is working with them to restore functionality. This will affect your ability to send and receive orders. We will use this page to provide updates.
Posted Jul 25, 2024 - 09:30 PDT
This incident affected: 3rd party services (Quest Diagnostics).