Issues with accessing patient charts and previewing and signing clinical notes
Incident Report for DrChrono
Postmortem

On 07/28, customers encountered issues related to being unable to open patient charts, preview or lock clinical notes, as well as uploading or downloading documents.

Timeline

All times are in PST.

Date/Time Activity
2022-07-28 05:35 Support tickets come in from customers having issues with opening patient charts, previewing or locking notes, including uploading and downloading documents.
2022-07-28 05:59 An internal communication channel is opened to coordinate with the engineering team.
2022-07-28 06:14 Status page is created and set to investigating status.
2022-07-28 06:21 The issue has been identified as a 3rd party outage and they confirm that they have resolved the issue.
2022-07-28 06:21 Status page is set to monitoring status
2022-07-28 06:59 Our 3rd party web service provider confirms that their services are back to operational status.
2022-07-28 07:03 Some impacted customers confirm that the issue is resolved on their end.
2022-07-28 11:00 Status page is set to resolved.

Contributing Factor(s)

Our system's reliance on Rackspace caused their outage to affect our systems.

Stabilization Steps

No direct operational changes were done, however our DevOps team monitored the 3rd party outage very closely to be constantly updated on when the issue is resolved.

Corrective Actions

Ongoing efforts are in place to migrate out of Rackspace which is expected to improve our platform’s performance.

Posted Aug 09, 2022 - 14:01 PDT

Resolved
After monitoring system performance for the last few hours, as well as feedback from customers, our team has confirmed that the issue has been resolved. The RCA will be made available on this page in the next few days.
Posted Jul 28, 2022 - 11:00 PDT
Monitoring
According to the third-party, their services have begun to recover. Their engineers continue to be engaged to confirm all systems have once again become accessible. The DrChrono engineers will also continue to be engaged with our team and customers to confirm all components of DrChrono have also become accessible.
Posted Jul 28, 2022 - 06:30 PDT
Identified
The issues have been identified as due to a third-party outage.
Posted Jul 28, 2022 - 06:21 PDT
Investigating
Currently, customers are experiencing issues with accessing patient charts and previewing and signing clinical notes. We are currently investigating these issues with the highest priority and we will continue to provide updates as we have them.
Posted Jul 28, 2022 - 06:14 PDT
This incident affected: drchrono.com and drchrono iPad EHR.