Site slowness
Incident Report for DrChrono
Resolved
This incident has been resolved.
Posted Oct 29, 2019 - 14:21 PDT
Investigating
We have received new reports of site slowness this morning and are currently investigating. Please contact our support team at drchrono.com/help with details related to any slowness/performance issues including where in the software you are experiencing them.
Posted Oct 29, 2019 - 08:41 PDT
This incident affected: drchrono.com and drchrono iPad EHR.