DrChrono Data Not Loading
Incident Report for DrChrono
Resolved
The incident causing a page to partially render and or look blank has been resolved by our teams. We are sorry for any issues this may have caused.
Posted Apr 24, 2024 - 10:30 PDT
Update
A subset of users are experiencing issues in the webapp, which we believe are related to the browser version, that may cause a page to partially render and or look blank. If you are experiencing this situation please submit a support ticket below and a member of support will be in contact.

The system is otherwise operating normally. If you experience this issue with Google Chrome, as a temporary workaround please access the DrChrono webapp using another browser including Firefox, Safari, and Microsoft Edge.

We are investigating the issue and will post updates every 2 hours.
Posted Apr 24, 2024 - 07:28 PDT
Update
DrChrono is experiencing a disruption in service. Users may be experiencing data not loading in multiple parts of the platform. We recommend using a different browser (Firefox, Safari, or Edge) as this issue is mainly affecting Google Chrome. We are investigating the issue and will post updates every 2 hours.
Posted Apr 24, 2024 - 04:39 PDT
Update
DrChrono is experiencing a disruption in service. Users may be experiencing data not loading in multiple parts of the platform. We recommend using a different browser (Firefox, Safari, or Edge) as this issue is mainly affecting Google Chrome. We are investigating the issue and will post updates every 60 minutes.
Posted Apr 23, 2024 - 14:11 PDT
Update
DrChrono is experiencing a disruption in service. Users may be experiencing data not loading in multiple parts of the platform. We recommend using a different browser (Firefox, Safari, or Edge) as this issue is mainly affecting Google Chrome. We are investigating the issue and will post updates every 60 minutes.
Posted Apr 23, 2024 - 11:58 PDT
Update
Our team continues to investigate the service interruption with data not loading and we will continue to provide updates every 60 minutes. Thank you for your patience.
Posted Apr 23, 2024 - 09:38 PDT
Investigating
DrChrono is experiencing a disruption in service. Users may be experiencing data not loading in multiple parts of the platform. We recommend using a different browser (Firefox, Safari, or Edge) as this issue is mainly affecting Google Chrome. We are investigating the issue and will post updates every 60 minutes.
Posted Apr 23, 2024 - 07:59 PDT
This incident affected: drchrono.com.