Issues with clinical notes, faxing (Document-generating services) and Something Went Wrong screen
Incident Report for DrChrono
Resolved
We've received an update that as of June 13th 3:37PM PDT, AWS services have been restored. DrChrono impacted functionalities should now be back to normal.

Our team will be preparing an RCA and will be available via this status page.
Posted Jun 14, 2023 - 06:05 PDT
Monitoring
We've received information that affected AWS services are seeing improvement in their error rates and are working towards full recovery. You may see improvements in DrChrono related to previously reported errors on accessing and saving clinical notes including faxing as a result.

If you continue to experience issues, please reach out to our Support team by submitting a ticket. Thank you for your patience.
Posted Jun 13, 2023 - 14:45 PDT
Investigating
We have received information that Amazon Web Services (AWS) services in the US-EAST are encountering significant issues due to AWS multiple service failure. We have identified that this impacts document-generating functions such as viewing, locking, downloading or saving clinical notes as well as sending out faxes.

Our team is working on ways to assess the impact of this and create mitigation steps.

We will post additional updates as more information becomes available.
Posted Jun 13, 2023 - 12:44 PDT
This incident affected: drchrono.com and drchrono iPad EHR.