Third Party Vendor- Square
Incident Report for DrChrono
Resolved
The issue with the payment processor, Square, has been resolved. Thank you for your patience and understanding.
Posted Sep 06, 2024 - 16:58 PDT
Monitoring
Our team has implemented a fix for this issue and our teams are monitoring the results. We will provide another update once we have confirmed this was successful in resolving the issue.
Posted Sep 06, 2024 - 15:01 PDT
Investigating
We are aware of the issues you are experiencing with the payment processor, Square. We are working with our internal teams on this and will continue to use this page to provide updates.
Posted Sep 06, 2024 - 12:14 PDT
This incident affected: drchrono.com and 3rd party services (Square).