Site-Wide Slowness
Incident Report for DrChrono
Resolved
This incident has been resolved.
Posted Jan 28, 2019 - 13:48 PST
Investigating
We are currently investigating a site wide slowness issue. Users may receive error messages for delayed response time. This may also affect our API response time.
Posted Jan 28, 2019 - 12:20 PST
This incident affected: drchrono.com.