Third Party Vendor: Quest Diagnostics

Incident Report for DrChrono

Resolved

Quest, our third-party vendor, has resolved the issue that may have impacted lab ordering and results transmission.

If you are still experiencing any lingering effects, please don't hesitate to reach out to Support at support@drchrono.com for assistance.
Posted Oct 10, 2024 - 08:13 PDT

Update

Quest, our third-party vendor, is still investigating their system issues that may impact lab ordering and results transmission. We will continue to use this page to monitor the status.

In the meantime, missing lab results can be accessed through the Quest Quanum portal: https://auth2.questdiagnostics.com/cas/login?service=https%3A%2F%2Fphysician.quanum.questdiagnostics.com%2Fhcp-server-web%2Flogin%2Fcas
Posted Oct 10, 2024 - 07:43 PDT

Investigating

Quest, our third-party vendor, has reported system issues that may impact lab ordering and results transmission. We will continue to use this page to monitor the status.

In the meantime, missing lab results can be accessed through the Quest Quanum portal: https://auth2.questdiagnostics.com/cas/login?service=https%3A%2F%2Fphysician.quanum.questdiagnostics.com%2Fhcp-server-web%2Flogin%2Fcas
Posted Oct 09, 2024 - 15:00 PDT
This incident affected: 3rd party services (Quest Diagnostics).