Site Wide Failure
Incident Report for drchrono
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 12, 2018 - 13:23 PDT
Monitoring
We have identified the issue with our service. Please press Cmd+Shift+R on Mac or Ctrl+Shift+R on PC to bypass the browser cache and reload the page. We will continue to monitor the issue closely and will provide additional updates via the status page if necessary.
Posted 6 months ago. Apr 12, 2018 - 13:08 PDT
Investigating
drchrono is currently experiencing a service outage. Please be aware that we take this very seriously and our engineering team is actively investigating and working to resolve this situation as quickly as possible. We will provide another update via this status page as soon as possible.
Posted 6 months ago. Apr 12, 2018 - 12:43 PDT