System slowness
Incident Report for DrChrono
Resolved
The issue has been resolved and Site performance is at normal levels.
Posted Feb 25, 2020 - 20:38 PST
Monitoring
We’ve applied a configuration to our servers and we are currently monitoring the changes.
Posted Feb 25, 2020 - 15:54 PST
Investigating
We are currently experiencing system slowness. We are investigating this issue and will post an update as soon as additional information is available.
Posted Feb 25, 2020 - 14:34 PST
This incident affected: drchrono.com and drchrono iPad EHR.