Drug Interaction Checker is not functioning
Incident Report for DrChrono
Resolved
This incident has been resolved.
Posted Mar 06, 2020 - 07:17 PST
Identified
The issue has been identified, and a fix is being implemented.
Posted Mar 06, 2020 - 07:06 PST
Investigating
We are currently investigating an issue with the drug interaction checker not detecting any drug interactions.
Posted Mar 06, 2020 - 06:51 PST
This incident affected: eRx service.