DrC Slowness

Incident Report for DrChrono

Resolved

Our team has resolved the issues related to system slowness. Please reach out to support if you continue to experience issues. We are sorry for the inconvenience this may have caused.
Posted Apr 02, 2024 - 15:23 PDT

Update

Our engineers have pushed a resolution and are monitoring the system at this time. We will move the status of this incident to resolve in the next 30 minutes.
Posted Apr 02, 2024 - 14:36 PDT

Monitoring

DrChrono is monitoring the system slowness.
Posted Apr 02, 2024 - 14:22 PDT

Investigating

DrChrono users may be experiencing slowness. We are working with our engineering team on a resolution. This page will be updated every hour for updates.
Posted Apr 02, 2024 - 13:06 PDT
This incident affected: drchrono.com.