DrChrono Intermittent Issues

Incident Report for DrChrono

Resolved

We have confirmed that the adjustments we implemented have fully resolved the issue and our systems are up and operational. We appreciate your patience as we worked through this matter.
Posted Jun 03, 2026 - 12:33 PDT

Monitoring

We have implemented corrective measures to resolve the issue causing intermittent slowness for some users. Initial results indicate that system performance has returned to normal.

Our team is actively monitoring the platform to ensure stability and confirm that the issue has been fully resolved. We will continue to provide updates as needed.

Thank you for your patience while we worked to address this issue.
Posted Jun 03, 2026 - 11:50 PDT

Update

Our team is still actively working on a fix for the issue. We will continue to monitor progress and provide updates as more information becomes available.
Posted Jun 03, 2026 - 10:22 PDT

Investigating

We are aware that some users may be experiencing intermittent errors when using the system.

Our Support team is currently working with our Engineering team to review and resolve the issue. We will continue to monitor the situation and provide updates as more information becomes available.
Posted Jun 03, 2026 - 08:49 PDT
This incident affected: drchrono.com and drchrono iPad EHR.