Issue with Square: Disruption in Payment Acceptance
Incident Report for DrChrono
Resolved
Message from Square:

We’re no longer seeing elevated levels of payment declines and card processing activity has returned to normal. Our team will continue to work with our partners on uncovering the underlying cause of the earlier disruption and putting in place safeguards to help prevent issues of this nature from recurring in the future.

We understand how important it is for all of our services to be running for your business, thank you for your patience with us as we monitored the situation.
Posted Feb 07, 2023 - 06:19 PST
Monitoring
Update from Square:

While we are seeing less elevated level of declines with most card carriers, we are continuing to see reports of declines when using Discover. If you continue to experience declines, please advise your customers to use an alternative card or form of payment.

We appreciate your patience as we continue to work on resolving this disruption. We will continue monitoring the situation and provide updates as we have them.
Posted Feb 06, 2023 - 15:11 PST
Investigating
We received information from Square that they are currently encountering a system issue related to accepting payments. To get direct updates about this incident, please visit this link: https://www.issquareup.com/incidents/v952qqw12x1c

We will continue to cross-post updates as we receive them.
Posted Feb 06, 2023 - 14:02 PST
This incident affected: 3rd party services (Square).