Connectivity Issues in NE United States

Incident Report for DrChrono

Resolved

This incident has been resolved.
Posted Apr 24, 2019 - 10:55 PDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 24, 2019 - 10:49 PDT

Identified

We are currently experiencing issues with Cloudflare, our content delivery network. We have received reports that some customers in the northeast United States are unable to access DrChrono. We are working with our partner Cloudflare to resolve the issue.
Posted Apr 24, 2019 - 08:53 PDT
This incident affected: drchrono.com.