Issue Loading Billing-Related Reports

Incident Report for DrChrono

Investigating

We are aware of an issue affecting a subset of users who are reporting that some billing related reports fail to load. This includes the Financial Transactions Report, Aging A/R Analysis, Denial Analysis, and other billing-related reports. Our team is actively investigating and will provide updates as more information becomes available.
Posted Feb 09, 2026 - 06:55 PST
This incident affects: drchrono.com.