Issue Previewing Clinical Notes and Uploading Documents
Incident Report for drchrono
Resolved
This incident has been resolved.
Posted 8 days ago. Jan 10, 2019 - 10:33 PST
Identified
Our engineers have identified a global issue where our customers are receiving 500 error messages when attempting to preview clinical notes, uploading documents, and reports generating in the message center. We are working to resolve this issue.
Posted 8 days ago. Jan 10, 2019 - 10:11 PST
This incident affected: drchrono.com.