Service Interruption
Incident Report for drchrono
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 15, 2018 - 21:31 PST
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Nov 15, 2018 - 20:53 PST
Investigating
We are currently experiencing downtime of the drchrono service, we are investigating and working to fix the issue for all affected users.
Posted about 1 month ago. Nov 15, 2018 - 20:51 PST
This incident affected: drchrono.com, drchrono iPad EHR, and drchrono iPad Check-In Kiosk Application.