DrChrono Intermittent Issues

Incident Report for DrChrono

Resolved

We have implemented a fix for the outage and the issue is resolved. We are sorry for the inconvenience. Please reach out to support for further questions.
Posted Dec 26, 2024 - 15:33 PST

Update

We are continuing to investigate this issue.
Posted Dec 26, 2024 - 11:21 PST

Investigating

DrChrono is experiencing a disruption with faxing and sending lab orders. We are investigating the issue and will continue to update this page. Please reach out to support for further questions.
Posted Dec 26, 2024 - 11:15 PST
This incident affected: drchrono.com.