Offices not appearing on the calendar page
Incident Report for DrChrono
Postmortem

Description

Following the 03/03/22 deployment, certain UI widgets disappeared for some users.

Timeline

All times are EST

Date/Time Activity
2022-03-02 23:30:00 First ticket describing issue filed
2022-03-03 07:00:00 Second ticket describing issue filed
2022-03-03 10:50:00 Issue reproduced internally
2022-03-03 11:10:00 Issue identified
2022-03-03 16:30:00 Hotfix deployed

Contributing Factor(s)

The URLs from which certain JavaScript files are loaded was changed following the 02/24/21 deployment. URLs for static assets typically include a cache-busting hash that changes on each deployment. This forces users' browsers to download the latest versions of those assets rather than using cached versions which may be stale.

Some of the updated URLs did not include a cache-busting hash. This would lead to errors being thrown when the user’s browser mixed JavaScript files from the previous deployment with those from the current deployment.

Stabilization Steps

Affected users are advised to do a hard refresh on affected pages by pressing Command + Shift + R (Mac Chrome/Firefox), Command + Option + R (Mac Safari), or Control + Shift + R (Windows Chrome/Firefox).

Impact

The following UI widgets may not appear until the user does a hard refresh:

  • Office list on the Calendar page
  • Telehealth settings on the Office Settings page
  • Cancel RX button on the Patient Dashboard page

Corrective Actions

The configuration issue that resulted in un-hashed URLs was resolved in a hotfix. No further action required by users.

Posted Mar 10, 2022 - 10:57 PST

Resolved
This incident has been resolved. We apologize for the inconvenience caused today. A post-mortem will be available via this status page incident within the next week.
Posted Mar 03, 2022 - 13:55 PST
Identified
Some users are experiencing an issue with offices not appearing on the calendar page. We are working on a permanent fix for this problem, but in the meantime performing a hard refresh of the webpage will cause the offices to appear again. The following instructions specify how to perform a hard refresh based on web browser and operating system:

For Mac, on Chrome and Firefox press Cmd+Shift+R.
Safari press Cmd+Option+R.

For Windows, all browsers Ctrl+F5
Posted Mar 03, 2022 - 11:22 PST
This incident affected: drchrono.com.